Buscando dependencias entre paquetes en Ubuntu con apt-rdepends

Hola a todos de nuevo,

en algunas ocasiones nos vemos en la necesidad de buscar todas las dependencias de un paquete. Hasta hace relativamente poco tiempo yo buscaba dicha informacion en aptitude, entrando en el paquete, o bien buscaba por Inet la información que me hacia falta. En este tutorial voy a explicar como usar la herramienta apt-rdepends para de forma recursiva listar todas las dependencias de un paquete Debian/Ubuntu.

1 Instalación de apt-rdepends

Puedes instalar apt-rdepends de la siguiente forma en el caso de que seas root:

apt-get install apt-rdepends

en otro caso deberás usar:

sudo apt-get install apt-rdepends

2 Usar apt-rdepends

apt-rdepends puede usarse como a continuación se indica

apt-rdepends <packagename>

Por ejemplo, si quisiésemos buscar todas las dependencias del paquete at de forma recursiva obtendriamos la siguiente información:

eloy@ubuntuEEEbox:~$ apt-rdepends at
Leyendo lista de paquetes… Hecho
Creando árbol de dependencias
Leyendo la información de estado… Hecho
at
Depende: libc6 (>= 2.7)
Depende: libpam0g (>= 0.99.7.1)
Depende: lsb-base (>= 3.2-14)
Depende: upstart-job
libc6
Depende: debconf (>= 0.5)
Depende: debconf-2.0
Depende: findutils (>= 4.4.0-2ubuntu2)
Depende: libc-bin (= 2.11.1-0ubuntu7)
Depende: libgcc1
Depende: tzdata
debconf
Depende: debconf-english
Depende: debconf-i18n
PreDepende: perl-base (>= 5.6.1-4)
debconf-english
Depende: debconf
debconf-i18n
Depende: debconf
Depende: liblocale-gettext-perl
Depende: libtext-charwidth-perl
Depende: libtext-iconv-perl
Depende: libtext-wrapi18n-perl
liblocale-gettext-perl
Depende: libc6 (>= 2.2)
PreDepende: perl-base (>= 5.10.0-24ubuntu4)
PreDepende: perlapi-5.10.0
perl-base
PreDepende: dpkg (>= 1.14.20)
PreDepende: libc6 (>= 2.11)
dpkg
PreDepende: coreutils (>= 5.93-1)
PreDepende: libc6 (>= 2.11)
PreDepende: lzma
coreutils
PreDepende: libacl1 (>= 2.2.11-1)
PreDepende: libattr1 (>= 2.4.41-1)
PreDepende: libc6 (>= 2.11)
PreDepende: libselinux1 (>= 1.32)
libacl1
Depende: libattr1 (>= 2.4.41-1)
Depende: libc6 (>= 2.4)
libattr1
Depende: libc6 (>= 2.4)
libselinux1
Depende: libc6 (>= 2.8)
lzma
Depende: libc6 (>= 2.4)
Depende: libgcc1 (>= 1:4.1.1)
Depende: libstdc++6 (>= 4.4.0)
libgcc1
Depende: gcc-4.4-base (= 4.4.3-4ubuntu5)
Depende: libc6 (>= 2.2.4)
gcc-4.4-base
libstdc++6
Depende: gcc-4.4-base (= 4.4.3-4ubuntu5)
Depende: libc6 (>= 2.4)
Depende: libgcc1
perlapi-5.10.0
libtext-charwidth-perl

Depende: libc6 (>= 2.1.3)
Depende: perl-base (>= 5.10.0-24ubuntu4)
Depende: perlapi-5.10.0
libtext-iconv-perl
Depende: libc6 (>= 2.1.3)
Depende: perl-base (>= 5.10.0-24ubuntu4)
Depende: perlapi-5.10.0
libtext-wrapi18n-perl
Depende: libtext-charwidth-perl
debconf-2.0
findutils

PreDepende: libc6 (>= 2.7)
libc-bin
tzdata

Depende: debconf (>= 0.5)
Depende: debconf-2.0
libpam0g
Depende: debconf (>= 0.5)
Depende: debconf-2.0
Depende: libc6 (>= 2.8)
lsb-base
Depende: ncurses-bin
Depende: sed
ncurses-bin
PreDepende: libc6 (>= 2.4)
PreDepende: libncurses5 (>= 5.6+20071006-3)
libncurses5
Depende: libc6 (>= 2.4)
sed
Depende: dpkg (>= 1.15.4)
Depende: install-info
PreDepende: libc6 (>= 2.4)
PreDepende: libselinux1 (>= 1.32)
install-info
Depende: libc6 (>= 2.4)
upstart-job
eloy@ubuntuEEEbox:~$

3 Links de interés

Nota: Recuerda de vez en cuando pinchar en la publicidad por favor.

You must be logged in to post a comment.